Bug suite à modif des profils

Signalez ici les bugs rencontrés. Essayez d'être précis et de donner un maximum de détails.
Dr.Gui
Messages : 3
Inscription : lun. 6 févr. 2017 14:59

Bug suite à modif des profils

Message par Dr.Gui » lun. 6 févr. 2017 17:17

Bonjour à tous.

Je suis en train de paramétrer ALMAPRO pour mon début d'activité qui aura lieu le 20/02.
Depuis le début de l'après-midi, je suis embêté par un problème lié à la modification des profils.

En clair, j'ai utilisé l'interface d'édition des profils via les options afin des peaufiner les profils et les adapter à ma pratique.
Mais depuis ces quelques modifications (rajout du calcul de l'IMC par exemple), impossible d'avoir accès la page de remplissage du profil lors de la saisie de la consultation.
J'ai d'emblée un message d'erreur, et ce quelque soit le patient sélectionné.
J'ai tout désinstallé 2 fois proprement (AlmaPro et MySQL) et tout réinstallé : toujours coincé.

"Le mécanisme de sécurité du WLangage a détecté une erreur dans l'application AlmaPro. Contactez le fournisseur de l'application AlmaPro."

Avec ce message :

"Erreur à la ligne 145 du traitement Procédure locale RemplirProfil.
L'élément 'Champ_6' est inconnu.

----- Informations techniques -----

Projet : AlmaPro

Appel WL :
Traitement de 'Procédure locale RemplirProfil' (FEN_PROFIL.PROCEDURE.RemplirProfil), ligne 145, thread 0

Que s'est-il passé ?
L'élément 'Champ_6' est inconnu.

Code erreur : 1059
Niveau : erreur fatale

Dump de l'erreur du module 'wd210vm.dll' (21.0.330.0).
Identifiant des informations détaillées (.err) : 1059
Informations supplémentaires :
EIT_PILEWL :
Procédure locale RemplirProfil (FEN_PROFIL.PROCEDURE.RemplirProfil), ligne 145
Fin d'initialisation de FEN_PROFIL (FEN_PROFIL), ligne 9
EIT_DATEHEURE : 06/02/2017 17:09:47
EIT_TYPE_WDFILE : <2>
EIT_IDCODE : <458752>

Assistance"

J'ai déjà eu une première réponse de l'assistance, mais les 2 solutions proposées ne fonctionnent pas et je reste coincé...

Est-ce déjà arrivé à l'un de vous? Quelqu'un a-t-il une idée pour résoudre le bazar?

Merci par avance pour votre aide et bonne soirée.

Guillaume

Avatar de l’utilisateur
TChatenet
Messages : 412
Inscription : mar. 21 févr. 2012 12:53
Localisation : Au milieu de l'océan

Re: Bug suite à modif des profils

Message par TChatenet » lun. 6 févr. 2017 17:33

Dr.Gui a écrit :Bonjour à tous.

Je suis en train de paramétrer ALMAPRO pour mon début d'activité qui aura lieu le 20/02.
Depuis le début de l'après-midi, je suis embêté par un problème lié à la modification des profils.

En clair, j'ai utilisé l'interface d'édition des profils via les options afin des peaufiner les profils et les adapter à ma pratique.
Mais depuis ces quelques modifications (rajout du calcul de l'IMC par exemple), impossible d'avoir accès la page de remplissage du profil lors de la saisie de la consultation.
J'ai d'emblée un message d'erreur, et ce quelque soit le patient sélectionné.
J'ai tout désinstallé 2 fois proprement (AlmaPro et MySQL) et tout réinstallé : toujours coincé.
Bonjour ,
Cela ne sert à rien de désinstaller et réinstaller AlmaPro si tu conserves ta base , le problème ne vient manifestement pas de l'application mais d'une donnée inappropriée mémorisée dans ta base . Idéalement il te faudrait restaurer une sauvegarde antérieure à la modif de la mort .
Le plantage a t il lieu quel que soit le profil sélectionné ( autrement dit affecte t il tous les profils ? )
Si tu as encore accès à l'écran d'options , modif des profils , as tu tenté de les nettoyer ?
Quelles sont les procédures que t'a communiqué le service technique et qui n'ont pas fonctionné ?

"Le mécanisme de sécurité du WLangage a détecté une erreur dans l'application AlmaPro. Contactez le fournisseur de l'application AlmaPro."

Avec ce message :

"Erreur à la ligne 145 du traitement Procédure locale RemplirProfil.
L'élément 'Champ_6' est inconnu.

----- Informations techniques -----

Projet : AlmaPro

Appel WL :
Traitement de 'Procédure locale RemplirProfil' (FEN_PROFIL.PROCEDURE.RemplirProfil), ligne 145, thread 0

Que s'est-il passé ?
L'élément 'Champ_6' est inconnu.

Code erreur : 1059
Niveau : erreur fatale

Dump de l'erreur du module 'wd210vm.dll' (21.0.330.0).
Identifiant des informations détaillées (.err) : 1059
Informations supplémentaires :
EIT_PILEWL :
Procédure locale RemplirProfil (FEN_PROFIL.PROCEDURE.RemplirProfil), ligne 145
Fin d'initialisation de FEN_PROFIL (FEN_PROFIL), ligne 9
EIT_DATEHEURE : 06/02/2017 17:09:47
EIT_TYPE_WDFILE : <2>
EIT_IDCODE : <458752>

Assistance"

J'ai déjà eu une première réponse de l'assistance, mais les 2 solutions proposées ne fonctionnent pas et je reste coincé...

Est-ce déjà arrivé à l'un de vous? Quelqu'un a-t-il une idée pour résoudre le bazar?

Merci par avance pour votre aide et bonne soirée.

Guillaume
Bonne journée
TC

Dr Aquilina
Messages : 10
Inscription : mer. 2 mars 2016 15:34

Re: Bug suite à modif des profils

Message par Dr Aquilina » mer. 7 juin 2017 14:44

Bonjour,

Avez-vous trouvé une solution à votre problème? J'ai exactement le même.
1 profil me fait planter le logiciel si je souhaite y noter une nouvelle donnée.
Je l'avais modifié en constatant que 2 calculs d'IMC s'y opéraient, mais avec 2 résultats différents !?!
En infra mon message d'erreur.

Merci pour vos aides,

Dr Aquilina

-------------------------------------------------------------------------------------------------------------------------------
Erreur à la ligne 145 du traitement Procédure locale RemplirProfil.
L'élément 'Champ_23' est inconnu.

----- Informations techniques -----

Projet : AlmaPro

Appel WL :
Traitement de 'Procédure locale RemplirProfil' (FEN_PROFIL.PROCEDURE.RemplirProfil), ligne 145, thread 0

Que s'est-il passé ?
L'élément 'Champ_23' est inconnu.

Code erreur : 1059
Niveau : erreur fatale
Dump de l'erreur du module 'wd210vm.dll' (21.0.330.0).
Identifiant des informations détaillées (.err) : 1059
Informations supplémentaires :
EIT_PILEWL :
Procédure locale RemplirProfil (FEN_PROFIL.PROCEDURE.RemplirProfil), ligne 145
Fin d'initialisation de FEN_PROFIL (FEN_PROFIL), ligne 9
EIT_DATEHEURE : 07/06/2017 17:37:59
EIT_TYPE_WDFILE : <2>
EIT_IDCODE : <458752>

Assistance

-------------------------------------------------------------------------------------------------------------------------------

Avatar de l’utilisateur
TChatenet
Messages : 412
Inscription : mar. 21 févr. 2012 12:53
Localisation : Au milieu de l'océan

Re: Bug suite à modif des profils

Message par TChatenet » mer. 7 juin 2017 16:26

Bonjour ,

J'ai eu la chance d'avoir à ma consultation il y a quelques années un personnage très intéressant issu d'une autre culture que la nôtre .
Il s'est assis face à moi dans l'attente de mon verdict sur son état de santé sans manifester l'intention de me fournir d'élément ou de me permettre de l'examiner .
Je lui ai consacré du temps pour lui expliquer que la médecine pratiquée dans notre monde occidental était un peu différente de celle à laquelle il était accoutumé.
Rien de magique chez nous :-/
Bonne journée
TC

Dr Aquilina
Messages : 10
Inscription : mer. 2 mars 2016 15:34

Re: Bug suite à modif des profils

Message par Dr Aquilina » mar. 13 juin 2017 13:51

Cher confrère

Je vous trouve d'une très grande spiritualité et d'une grande finesse. Vous avez ébloui mon après-midi.

Je pensais mon message clair, mais apparemment il ne l'est pas pour vous.
Si vous avez besoin d'une information supplémentaire, vous pouvez me la demander explicitement.

Si vous ne souhaitez pas apporter votre aide, rien ne vous oblige à répondre, et dans ce cas, ne faites pas le troll, comme on dit dans le jargon.

Très cordialement,

Julien Aquilina (Le Tampon)

Dr Aquilina
Messages : 10
Inscription : mer. 2 mars 2016 15:34

Re: Bug suite à modif des profils

Message par Dr Aquilina » mar. 13 juin 2017 14:48

Si cela peut aider quelqu'un:

Problème résolu en supprimant le profil incriminé.
J'avais peur que mes données spécifiques à ce profil soient supprimées, mais il n'en est rien, les données sont transférées (avec un petit temps de traitement) vers le profil standard.

Avatar de l’utilisateur
TChatenet
Messages : 412
Inscription : mar. 21 févr. 2012 12:53
Localisation : Au milieu de l'océan

Re: Bug suite à modif des profils

Message par TChatenet » mar. 13 juin 2017 20:33

Dr.Gui a écrit : En clair, j'ai utilisé l'interface d'édition des profils via les options afin des peaufiner les profils et les adapter à ma pratique.
Mais depuis ces quelques modifications (rajout du calcul de l'IMC par exemple), impossible d'avoir accès la page de remplissage du profil lors de la saisie de la consultation.
Dr Aquilina a écrit : Avez-vous trouvé une solution à votre problème? J'ai exactement le même.
1 profil me fait planter le logiciel si je souhaite y noter une nouvelle donnée.
Je l'avais modifié en constatant que 2 calculs d'IMC s'y opéraient, mais avec 2 résultats différents !?!
En infra mon message d'erreur.
Désolé de t'avoir froissé Sheldon mais non , ton message n'est pas clair
1 profil ( lequel , quelles questions contient il ? ) que tu as modifié car deux calculs d'IMC s'y opéraient ( deux fois la même question ? deux questions différentes , lesquelles dans ce cas car chez moi il n'existe qu'une question se rapportant à l'IMC ).
Comment veux tu que l'on reproduise ton problème ?, comment veux tu que l'on y réponde ? t'es tu posé la question ?
Dr Aquilina a écrit : Problème résolu en supprimant le profil incriminé.
J'avais peur que mes données spécifiques à ce profil soient supprimées, mais il n'en est rien, les données sont transférées (avec un petit temps de traitement) vers le profil standard.
Content que ton problème soit résolu , merci de ton témoignage même s'il ne fait pas beaucoup avancer le schmilblick . Je marque le sujet comme résolu même si le problème reste sans réponse puisqu'il n'a pas été identifié.
Dr Aquilina a écrit : Je vous trouve d'une très grande spiritualité et d'une grande finesse. Vous avez ébloui mon après-midi.
Je craignais d'avoir perdu mon temps en cherchant à reproduire mais je vois qu'il n'en est rien, au moins tu t'es bien amusé ..
Bonne journée
TC

Répondre