[Résolu]connexion au serveur pas possible

Réseaux informatiques, postes serveur et client, mode visite.
dicodin
Messages : 12
Inscription : mer. 17 oct. 2012 18:14

[Résolu]connexion au serveur pas possible

Message par dicodin » mar. 8 déc. 2015 12:45

Bonjour
Après avoir réinstallé Almapro sur un nouveau disque dur (windows 8.1), je n'arrive plus à établir une connection avec le poste serveur.
Mon associée (qui n'a fait aucune modification) y parvient sans souci.
Je pense donc qu'il y a un problème entre mon PC et le serveur, et non sur le serveur seul.

Le message d'erreur est le suivant (sachant que Blackmagic est le nom du serveur):
Erreur de l'accès natif MySQL.
Numéro d'erreur = 79
Echec de la connexion.
L'erreur suivante a été renvoyée par la base de données <BLACKMAGIC> :
Numéro d'erreur = <2003>.
Message d'erreur :
Can't connect to MySQL server on 'BLACKMAGIC' (10060)

J'ai pourtant suivi les instructions du guide "réinstaller Almapro sur un nouveau poste client".
Almapro sur le client s'exécute en tant qu'admin;
la BCB a été installée sur le client;
le partage par mot de passe est désactivé (mais ce n'est pas comme sur la capture d'écran : la seule possibilité de désactiver se trouve dans la sous-section "tous les réseaux");
le groupe de travail est identique;
dans la configuration réseau, j'ai choisi le serveur, et non les autres PC branchés sur le même réseau;
Les UAC sont désactivés.
Je n'ai que le pare feu Windows et un antivirus Avast.

Merci à la personne qui pourra me sortir de ce pétrin.
Robert Shin

Avatar de l’utilisateur
TChatenet
Messages : 381
Inscription : mar. 21 févr. 2012 12:53
Localisation : Au milieu de l'océan

Re: connexion au serveur pas possible

Message par TChatenet » mar. 8 déc. 2015 17:34

une réponse rapide

le code d'erreur mysql que tu donnes est un code d'erreur généralement provoqué par un problème de pare - feu .
Vérifies que ceux ci soient bien configurés sur ton install ( serveur et client , je crois me souvenir qu'il faut ouvrir le port 3306 , à vérifier sur les doc )

[Edit] L'adresse IP de ton serveur est elle correcte sur l'afficheur réseau de ton poste client ?
Bonne journée
TC

dicodin
Messages : 12
Inscription : mer. 17 oct. 2012 18:14

Re: connexion au serveur pas possible

Message par dicodin » jeu. 10 déc. 2015 20:00

Bonjour
Effectivement l'adresse du serveur n'était plus bonne.
Après avoir corrigé cela, j'arrive enfin à me connecter sur le client.
L'outil de config réseau d'Almapro listait pourtant tous les ordis présents.
Il me reste à régler un souci avec la BCB et les en-têtes.
Merci pour votre aide encore
Robert Shin

Avatar de l’utilisateur
TChatenet
Messages : 381
Inscription : mar. 21 févr. 2012 12:53
Localisation : Au milieu de l'océan

Re: connexion au serveur pas possible

Message par TChatenet » jeu. 10 déc. 2015 20:07

Merci de ta réponse , ton expérience enrichit le forum ! :-)
Je marque le problème comme résolu !
Bonne journée
TC

Répondre